This user guide describes how to use the National Instruments USB-6008/6009 data acquisition (DAQ) devices and lists specifications.

Introduction

The NI USB-6008/6009 provides connection to eight analog input (AI) channels, two analog output (AO) channels, 12 digital input/output (DIO) channels, and a 32-bit counter with a Full-Speed USB interface.

Note This manual revision updates naming conventions to reflect the conventions used in NI-DAQmx. Table 1 notes the correlation between the old and updated names.

<table>
<thead>
<tr>
<th>Hardware Functionality</th>
<th>NI-DAQmx Terminology</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open-drain</td>
<td>Open collector</td>
</tr>
<tr>
<td>Push-pull</td>
<td>Active drive</td>
</tr>
</tbody>
</table>
### Table 2. Differences Between the NI USB-6008 and NI USB-6009

<table>
<thead>
<tr>
<th>Feature</th>
<th>NI USB-6008</th>
<th>NI USB-6009</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI Resolution</td>
<td>12 bits differential, 11 bits single-ended</td>
<td>14 bits differential, 13 bits single-ended</td>
</tr>
<tr>
<td>Maximum AI Sample Rate, Single Channel*</td>
<td>10 kS/s</td>
<td>48 kS/s</td>
</tr>
<tr>
<td>Maximum AI Sample Rate, Multiple Channels (Aggregate)*</td>
<td>10 kS/s</td>
<td>48 kS/s</td>
</tr>
<tr>
<td>DIO Configuration</td>
<td>Open collector</td>
<td>Open collector or active drive</td>
</tr>
</tbody>
</table>

* System dependent.

**Figure 1.** NI USB-6008/6009 Top View

**Figure 2.** NI USB-6008/6009 Back View
Dimensions

Figure 3 illustrates the dimensions of the NI USB-6008/6009 device.

Safety Guidelines

⚠️ Caution  Operate the NI USB-6008/6009 only as described in these operating instructions.

The following section contains important safety information that you must follow when installing and using the NI USB-6008/6009.

Do not operate the NI USB-6008/6009 in a manner not specified in this document. Misuse of the device can result in a hazard. You can compromise the safety protection built into the device if the device is damaged in any way. If the device is damaged, contact National Instruments for repair.

Do not substitute parts or modify the device except as described in this document. Use the device only with the chassis, modules, accessories, and cables specified in the installation instructions. You must have all covers and filler panels installed during operation of the device.
Do not operate the device in an explosive atmosphere or where there may be flammable gases or fumes. If you must operate the device in such an environment, it must be in a suitably rated enclosure.

If you need to clean the device, use a dry cloth. Make sure that the device is completely dry and free from contaminants before returning it to service.

Operate the device only at or below Pollution Degree 2. Pollution is foreign matter in a solid, liquid, or gaseous state that can reduce dielectric strength or surface resistivity. The following is a description of pollution degrees:

- Pollution Degree 1 means no pollution or only dry, nonconductive pollution occurs. The pollution has no influence.
- Pollution Degree 2 means that only nonconductive pollution occurs in most cases. Occasionally, however, a temporary conductivity caused by condensation must be expected.
- Pollution Degree 3 means that conductive pollution occurs, or dry, nonconductive pollution occurs that becomes conductive due to condensation.

You must insulate signal connections for the maximum voltage for which the device is rated. Do not exceed the maximum ratings for the device. Do not install wiring while the device is live with electrical signals. Do not remove or add connector blocks when power is connected to the system. Avoid contact between your body and the connector block signal when hot swapping modules. Remove power from signal lines before connecting them to or disconnecting them from the device.

Operate the device at or below the Measurement Category I\(^1\). Measurement circuits are subjected to working voltages\(^2\) and transient stresses (overvoltage) from the circuit to which they are connected during measurement or test. Measurement categories establish standard impulse withstand voltage levels that commonly occur in electrical distribution systems. The following is a description of measurement categories:

- Measurement Category I is for measurements performed on circuits not directly connected to the electrical distribution system referred to as MAINS\(^3\) voltage. This category is for measurements of voltages from specially protected secondary circuits. Such voltage measurements include signal levels, special equipment, limited-energy parts of equipment, circuits powered by regulated low-voltage sources, and electronics.

---

\(^1\) Measurement Category as defined in electrical safety standard IEC 61010-1. Measurement Category is also referred to as Installation Category.

\(^2\) Working Voltage is the highest rms value of an AC or DC voltage that can occur across any particular insulation.

\(^3\) MAINS is defined as a hazardous live electrical supply system that powers equipment. Suitably rated measuring circuits may be connected to the MAINS for measuring purposes.
Measurement Category II is for measurements performed on circuits directly connected to the electrical distribution system. This category refers to local-level electrical distribution, such as that provided by a standard wall outlet (for example, 115 V for U.S. or 230 V for Europe). Examples of Measurement Category II are measurements performed on household appliances, portable tools, and similar E Series devices.

Measurement Category III is for measurements performed in the building installation at the distribution level. This category refers to measurements on hard-wired equipment such as equipment in fixed installations, distribution boards, and circuit breakers. Other examples are wiring, including cables, bus-bars, junction boxes, switches, socket-outlets in the fixed installation, and stationary motors with permanent connections to fixed installations.

Measurement Category IV is for measurements performed at the primary electrical supply installation (<1,000 V). Examples include electricity meters and measurements on primary overcurrent protection devices and on ripple control units.

Related Documentation

Each application software package and driver includes information about writing applications for taking measurements and controlling measurement devices. The following references to documents assume you have NI-DAQmx 8.7 or later, and where applicable, version 7.1 or later of the NI application software.

NI-DAQmx for Windows

The DAQ Getting Started Guide describes how to install your NI-DAQmx for Windows software, how to install your NI-DAQmx-supported DAQ device, and how to confirm that your device is operating properly. Select Start>All Programs>National Instruments>NI-DAQ>DAQ Getting Started Guide.

The NI-DAQ Readme lists which devices are supported by this version of NI-DAQ. Select Start>All Programs>National Instruments>NI-DAQ>NI-DAQ Readme.

The NI-DAQmx Help contains general information about measurement concepts, key NI-DAQmx concepts, and common applications that are applicable to all programming environments. Select Start>All Programs>National Instruments>NI-DAQ>NI-DAQmx Help.

Note For information about non-Windows operating system support, refer to ni.com/info and enter BaseGSGML.
LabVIEW

If you are a new user, use the *Getting Started with LabVIEW* manual to familiarize yourself with the LabVIEW graphical programming environment and the basic LabVIEW features you use to build data acquisition and instrument control applications. Open the *Getting Started with LabVIEW* manual by selecting *Start»All Programs»National Instruments»LabVIEW»LabVIEW Manuals* or by navigating to the `labview\manuals` directory and opening `LV_Getting_Started.pdf`.

Use the *LabVIEW Help*, available by selecting *Help»Search the LabVIEW Help* in LabVIEW, to access information about LabVIEW programming concepts, step-by-step instructions for using LabVIEW, and reference information about LabVIEW VIs, functions, palettes, menus, and tools. Refer to the following locations on the *Contents* tab of the *LabVIEW Help* for information about NI-DAQmx:

- **Getting Started»Getting Started with DAQ**—Includes overview information and a tutorial to learn how to take an NI-DAQmx measurement in LabVIEW using the DAQ Assistant.
- **VI and Function Reference»Measurement I/O VIs and Functions**—Describes the LabVIEW NI-DAQmx VIs and properties.
- **Taking Measurements**—Contains the conceptual and how-to information you need to acquire and analyze measurement data in LabVIEW, including common measurements, measurement fundamentals, NI-DAQmx key concepts, and device considerations.

LabWindows/CVI


Measurement Studio

If you program your NI-DAQmx-supported device in Measurement Studio using Visual C++, Visual C#, or Visual Basic .NET, you can interactively create channels and tasks by launching the DAQ Assistant from MAX or from within Visual Studio .NET. You can generate the configuration code
based on your task or channel in Measurement Studio. Refer to the DAQ Assistant Help for additional information about generating code. You also can create channels and tasks, and write your own applications in your ADE using the NI-DAQmx API.

For help with NI-DAQmx methods and properties, refer to the NI-DAQmx .NET Class Library or the NI-DAQmx Visual C++ Class Library included in the NI Measurement Studio Help. For general help with programming in Measurement Studio, refer to the NI Measurement Studio Help, which is fully integrated with the Microsoft Visual Studio .NET help. To view this help file in Visual Studio .NET, select Measurement Studio» NI Measurement Studio Help.

To create an application in Visual C++, Visual C#, or Visual Basic .NET, follow these general steps:

1. In Visual Studio .NET, select File»New»Project to launch the New Project dialog box.
2. Find the Measurement Studio folder for the language you want to create a program in.
3. Choose a project type. You add DAQ tasks as a part of this step.

**ANSI C without NI Application Software**

The NI-DAQmx Help contains API overviews and general information about measurement concepts. Select Start»All Programs»National Instruments»NI-DAQ»NI-DAQmx Help.

The NI-DAQmx C Reference Help describes the NI-DAQmx Library functions, which you can use with National Instruments data acquisition devices to develop instrumentation, acquisition, and control applications. Select Start»All Programs»National Instruments»NI-DAQ»NI-DAQmx C Reference Help.

**.NET Languages without NI Application Software**

With the Microsoft .NET Framework version 1.1 or later, you can use NI-DAQmx to create applications using Visual C# and Visual Basic .NET without Measurement Studio. You need Microsoft Visual Studio .NET 2003 or Microsoft Visual Studio 2005 for the API documentation to be installed.

The installed documentation contains the NI-DAQmx API overview, measurement tasks and concepts, and function reference. This help is fully integrated into the Visual Studio .NET documentation. To view the NI-DAQmx .NET documentation, go to Start»Programs»National Instruments»NI-DAQ»NI-DAQmx .NET Reference Help. Expand NI Measurement Studio Help»NI Measurement Studio .NET Class.
Device Documentation and Specifications

NI-DAQmx includes the Device Document Browser, which contains online documentation for supported DAQ and SCXI devices, such as documents describing device pinouts, features, and operation. You can find, view, and/or print the documents for each device using the Device Document Browser at any time by inserting the CD. After installing the Device Documentation Browser, device documents are accessible from Start»All Programs>National Instruments>NI-DAQ>Browse Device Documentation.

Note You can also download these documents at ni.com/manuals.

NI-DAQmx Base (Linux/Mac OS X/LabVIEW PDA 8.x)

The NI-DAQmx Base Getting Started Guide describes how to install your NI-DAQmx Base software, your NI-DAQmx Base-supported DAQ device, and how to confirm that your device is operating properly. In Windows, select Start»All Programs>National Instruments>NI-DAQmx Base>Documentation>Getting Started Guide.

Getting Started with NI-DAQmx Base for Linux and Mac Users describes how to install your NI-DAQmx Base software, your NI-DAQmx Base-supported DAQ device, and how to confirm that your device is operating properly on your Mac/Linux machine.

The NI-DAQmx Base Readme lists which devices are supported by this version of NI-DAQmx Base. In Windows, select Start»All Programs>National Instruments>NI-DAQmx Base>DAQmx Base Readme.


Note All NI-DAQmx Base documentation for Linux is installed at /usr/local/natinst/nidaqmxbase/documentation.

Note All NI-DAQmx Base documentation for Mac OS X is installed at /Applications/National Instruments/NI-DAQmx Base/documentation.

Training Courses

If you need more help getting started developing an application with NI products, NI offers training courses. To enroll in a course or obtain a detailed course outline, refer to ni.com/training.

Technical Support on the Web

For additional support, refer to ni.com/support or zone.ni.com.

Installing the Software

Software support for the NI USB-6008/6009 for Windows Vista/XP/2000 is provided by NI-DAQmx. The DAQ Getting Started Guide, which you can download at ni.com/manuals, offers NI-DAQmx users step-by-step instructions for installing software and hardware, configuring channels and tasks, and getting started developing an application.

Note For information about non-Windows operating system support, refer to ni.com/info and enter BaseGSGML.

Installing Other Software

If you are using other software, refer to the installation instructions that accompany your software.

Example Programs

The NI-DAQmx CD contains example programs that you can use to get started programming with the NI USB-6008/6009. Refer to the NI-DAQmx for USB Devices Getting Started Guide that shipped with your device, and is also accessible from Start→All Programs→National Instruments→NI-DAQ, for more information.

The NI-DAQmx Base software ships with example programs you can use to get started programming with the NI USB-6008/6009. Refer to the NI-DAQmx Base Getting Started Guide that shipped with your device, and is also accessible from Start→All Programs→National Instruments→NI-DAQmx Base→Documentation, for more information.
Note  For information about non-Windows operating system support, refer to ni.com/ info and enter BaseGSXML.

Installing the NI USB-6008/6009 Device

Before installing the device, you must install the software you plan to use with the device. Refer to the Installing the Software section of this guide and the documentation included with the software for more information.

Figure 4 shows key functional components of the NI USB-6008/6009.

Figure 4. Device Block Diagram
Setting Up the NI USB-6008/6009 Device

Complete the following steps to set up the NI USB-6008/6009:

1. Install combicon screw terminal blocks by inserting them into the combicon jacks.

2. Figure 5 illustrates the signal labels that ship in the NI USB-6008/6009 kit. You can apply the signal labels to the screw terminal blocks for easy signal identification.

3. Refer to Table 4 and Figures 5 and 6 for signal label orientation and affix the provided signal labels to the screw terminal blocks. Until the signal labels are applied, you can insert the screw terminal blocks into either of the combicon jacks.
**Note** Once you label the screw terminal blocks, you must only insert them into the matching combicon jack, as indicated by the overlay label on the NI USB-6008/6009 device.

4. Connect the wiring to the appropriate screw terminals.
Connecting the NI USB-608/6009 to a Computer

Plug one end of the USB cable into the NI USB-6008/6009 and the other end into an available USB port on the computer.

LED Indicator

The NI USB-6008/6009 device has a green LED next to the USB connector. The LED indicator indicates device status, as listed in Table 3. When the device is connected to a USB port, the LED blinks steadily to indicate that the device is initialized and is receiving power from the connection.

If the LED is not blinking, it may mean that the device is not initialized or the computer is in standby mode. In order for the device to be recognized, the device must be connected to a computer that has NI-DAQmx installed on it. If your device is not blinking, make sure your computer has the latest version of NI-DAQmx installed on it, and the computer is not in standby mode.

<table>
<thead>
<tr>
<th>LED State</th>
<th>Device Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not lit</td>
<td>Device not connected or in suspend.</td>
</tr>
<tr>
<td>On, not blinking</td>
<td>Device connected.</td>
</tr>
<tr>
<td>Single-blink</td>
<td>Operating normally.</td>
</tr>
</tbody>
</table>
I/O Connector

The NI USB-6008/6009 ships with one detachable screw terminal block for analog signals and one detachable screw terminal block for digital signals. These terminal blocks provide 16 connections that use 16 AWG to 28 AWG wire.

Table 4 lists the analog terminal assignments, and Table 5 lists the digital terminal assignments.

**Table 4. Analog Terminal Assignments**

<table>
<thead>
<tr>
<th>Module</th>
<th>Terminal</th>
<th>Signal, Single-Ended Mode</th>
<th>Signal, Differential Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>GND</td>
<td>GND</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>AI 0</td>
<td>AI 0+</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>AI 4</td>
<td>AI 0–</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>GND</td>
<td>GND</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>AI 1</td>
<td>AI 1+</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>AI 5</td>
<td>AI 1–</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>GND</td>
<td>GND</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>AI 2</td>
<td>AI 2+</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>AI 6</td>
<td>AI 2–</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>GND</td>
<td>GND</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>AI 3</td>
<td>AI 3+</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>AI 7</td>
<td>AI 3–</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>GND</td>
<td>GND</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>AO 0</td>
<td>AO 0</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>AO 1</td>
<td>AO 1</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>GND</td>
<td>GND</td>
<td></td>
</tr>
<tr>
<td>Module</td>
<td>Terminal</td>
<td>Signal</td>
<td></td>
</tr>
<tr>
<td>-------</td>
<td>---------</td>
<td>----------</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>P0.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>P0.1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>P0.2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>P0.3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>P0.4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>P0.5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>P0.6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>P0.7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>P1.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>P1.1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>P1.2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>P1.3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>PFI 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>+2.5 V</td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td>+5 V</td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>GND</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Signal Descriptions

Table 6 describes the signals available on the I/O connectors.

<table>
<thead>
<tr>
<th>Signal Name</th>
<th>Reference</th>
<th>Direction</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GND</td>
<td>—</td>
<td>—</td>
<td><strong>Ground</strong>—The reference point for the single-ended AI measurements, bias current return point for differential mode measurements, AO voltages, digital signals at the I/O connector, +5 VDC supply, and the +2.5 VDC reference.</td>
</tr>
<tr>
<td>AI &lt;0..7&gt;</td>
<td>Varies</td>
<td>Input</td>
<td><strong>Analog Input Channels 0 to 7</strong>—For single-ended measurements, each signal is an analog input voltage channel. For differential measurements, AI 0 and AI 4 are the positive and negative inputs of differential analog input channel 0. The following signal pairs also form differential input channels: &lt;AI 1, AI 5&gt;, &lt;AI 2, AI 6&gt;, and &lt;AI 3, AI 7&gt;.</td>
</tr>
<tr>
<td>AO 0</td>
<td>GND</td>
<td>Output</td>
<td><strong>Analog Channel 0 Output</strong>—Supplies the voltage output of AO channel 0.</td>
</tr>
<tr>
<td>AO 1</td>
<td>GND</td>
<td>Output</td>
<td><strong>Analog Channel 1 Output</strong>—Supplies the voltage output of AO channel 1.</td>
</tr>
<tr>
<td>P1.&lt;0..3&gt;</td>
<td>GND</td>
<td>Input or Output</td>
<td><strong>Digital I/O Signals</strong>—You can individually configure each signal as an input or output.</td>
</tr>
<tr>
<td>P0.&lt;0..7&gt;</td>
<td>GND</td>
<td>Input or Output</td>
<td></td>
</tr>
<tr>
<td>+2.5 V</td>
<td>GND</td>
<td>Output</td>
<td><strong>+2.5 V External Reference</strong>—Provides a reference for wrap-back testing.</td>
</tr>
<tr>
<td>+5 V</td>
<td>GND</td>
<td>Output</td>
<td><strong>+5 V Power Source</strong>—Provides +5 V power up to 200 mA.</td>
</tr>
<tr>
<td>PFI 0</td>
<td>GND</td>
<td>Input</td>
<td><strong>PFI 0</strong>—This pin is configurable as either a digital trigger or an event counter input.</td>
</tr>
</tbody>
</table>
Analog Input

You can connect analog input signals to the NI USB-6008/6009 through the I/O connector. Refer to Table 6 for more information about connecting analog input signals.

Analog Input Circuitry

Figure 7 illustrates the analog input circuitry of the NI USB-6008/6009.

![Analog Input Circuitry Diagram]

**MUX**

The NI USB-6008/6009 has one analog-to-digital converter (ADC). The multiplexer (MUX) routes one AI channel at a time to the PGA.

**PGA**

The programmable-gain amplifier provides input gains of 1, 2, 4, 5, 8, 10, 16, or 20 when configured for differential measurements and gain of 1 when configured for single-ended measurements. The PGA gain is automatically calculated based on the voltage range selected in the measurement application.

**A/D Converter**

The analog-to-digital converter (ADC) digitizes the AI signal by converting the analog voltage into a digital code.
**AI FIFO**

The NI USB-6008/6009 can perform both single and multiple A/D conversions of a fixed or infinite number of samples. A first-in-first-out (FIFO) buffer holds data during AI acquisitions to ensure that no data is lost.

**Analog Input Modes**

You can configure the AI channels on the NI USB-6008/6009 to take single-ended or differential measurements. Refer to Table 6 for more information about I/O connections for single-ended or differential measurements.

**Connecting Differential Voltage Signals**

For differential signals, connect the positive lead of the signal to the AI+ terminal, and the negative lead to the AI– terminal.

![Connecting a Differential Voltage Signal](image_url)

**Figure 8.** Connecting a Differential Voltage Signal

The differential input mode can measure ±20 V signals in the ±20 V range. However, the maximum voltage on any one pin is ±10 V with respect to GND. For example, if AI 1 is +10 V and AI 5 is −10 V, then the measurement returned from the device is +20 V.
Connecting a signal greater than ±10 V on either pin results in a clipped output.

**Connecting Reference Single-Ended Voltage Signals**

To connect reference single-ended voltage signals (RSE) to the NI USB-6008/6009, connect the positive voltage signal to the desired AI terminal, and the ground signal to a GND terminal, as illustrated in Figure 11.

When no signals are connected to the analog input terminal, the internal resistor divider may cause the terminal to float to approximately 1.4 V when the analog input terminal is configured as RSE. This behavior is normal and does not affect the measurement when a signal is connected.
Digital Trigger

When an AI task is defined, you can configure PFI 0 as a digital trigger input. When the digital trigger is enabled, the AI task waits for a rising or falling edge on PFI 0 before starting the acquisition. To use ai/Start Trigger with a digital source, specify PFI 0 as the source and select rising or falling edge.

Analog Output

The NI USB-6008/6009 has two independent AO channels that can generate outputs from 0–5 V. All updates of AO lines are software-timed.

Analog Output Circuitry

Figure 12 illustrates the analog output circuitry for the NI USB-6008/6009.
DACs
Digital-to-analog converts (DACs) convert digital codes to analog voltages.

Connecting Analog Output Loads
To connect loads to the NI USB-6008/6009, connect the positive lead of the load to the AO terminal, and connect the ground of the load to a GND terminal.

Minimizing Glitches on the Output Signal
When you use a DAC to generate a waveform, you may observe glitches in the output signal. These glitches are normal; when a DAQ switches from one voltage to another, it produces glitches due to released charges. The largest glitches occur when the most significant bit of the DAC code changes. You can build a lowpass deglitching filter to remove some of these glitches, depending on the frequency and nature of the output signal. Refer to ni.com/support for more information about minimizing glitches.

Digital I/O
The NI USB-6008/6009 has 12 digital lines, P0.<0..7> and P1.<0..3>, which comprise the DIO port. GND is the ground-reference signal for the DIO port. You can individually program all lines as inputs or outputs.
Digital I/O Circuitry

Figure 14 shows P0.<0..7> connected to example signals configured as digital inputs and digital outputs. You can configure P1.<0..3> similarly.

![DIAGRAM] Figure 14. Example of Connecting a Load

1. P0.0 configured as an open collector digital output driving a LED
2. P0.2 configured as a active drive digital output driving a LED
3. P0.4 configured as a digital input receiving a TTL signal from a gated inverter
4. P0.7 configured as a digital input receiving a 0 V or 5 V signal from a switch

⚠️ **Caution** Exceeding the maximum input voltage ratings or maximum output ratings, which are listed in the Specifications section, can damage the device and the computer. National Instruments is not liable for any damage resulting from such signal connections.

**Source/Sink Information**

The default configuration of the NI USB-6008/6009 DIO ports is open collector, allowing 5 V operation, with an onboard 4.7 kΩ pull-up resistor. An external user-provided pull-up resistor can be added to increase the source current drive up to a 8.5 mA limit per line as shown in Figure 15.

The NI USB-6009 ports can also be configured as active drive using the NI-DAQmx API, allowing 3.3 V operation with a source/sink current limit of ±8.5 mA. Refer to the **NI-DAQmx Help** for more information about how to set the DIO configuration.
Complete the following steps to determine the value of the user-provided pull-up resistor:

1. Place an ammeter in series with the load.
2. Place a variable resistor between the digital output line and the +5 V.
3. Adjust the variable resistor until the ammeter current reads as the intended current. The intended current must be less than 8.5 mA.
4. Remove the ammeter and variable resistor from your circuit.
5. Measure the resistance of the variable resistor. The measured resistance is the ideal value of the pull-up resistor.
6. Select a static resistor value for your pull-up resistor that is greater than or equal to the ideal resistance.
7. Re-connect the load circuit and the pull-up resistor.
I/O Protection

To protect the NI USB-6008/6009 against overvoltage, undervoltage, and overcurrent conditions, as well as ESD events, you should avoid these fault conditions by using the following guidelines:

- If you configure a DIO line as an output, do not connect it to any external signal source, ground signal, or power supply.
- If you configure a DIO line as an output, understand the current requirements of the load connected to these signals. Do not exceed the specified current output limits of the DAQ device.
  National Instruments has several signal conditioning solutions for digital applications requiring high current drive.
- If you configure a DIO line as an input, do not drive the line with voltages outside of its normal operating range. The DIO lines have a smaller operating range than the AI signals.
- Treat the DAQ device as you would treat any static sensitive device. Always properly ground yourself and the equipment when handling the DAQ device or connecting to it.

Power-On States

At system startup and reset, the hardware sets all DIO lines to high-impedance inputs. The DAQ device does not drive the signal high or low. Each line has a weak pull-up resistor connected to it.

Static DIO

Each of the NI USB-6008/6009 DIO lines can be used as a static DI or DO line. You can use static DIO lines to monitor or control digital signals. All samples of static DI lines and updates of DO lines are software-timed.

Event Counter

You can configure PFI 0 as a source for a gated inverter counter input edge count task. In this mode, falling-edge events are counted using a 32-bit counter. For more information about event timing requirements, refer to the Specifications section.
Reference and Power Sources

The NI USB-6008/6009 creates an external reference and supplies a power source. All voltages are relative to COM unless otherwise noted.

+2.5 External References

The NI USB-6008/6009 creates a high-purity reference voltage supply for the ADC using a multi-state regulator, amplifier, and filter circuit. The resulting +2.5 V reference voltage can be used as a signal for self test.

+5 V Power Source

The NI USB-6008/6009 supplies a 5 V, 200 mA output. This source can be used to power external components.

Note While the device is in USB suspend, the output is disabled.

Specifications

The following specifications are typical at 25 °C, unless otherwise noted.

Analog Input

Converter type........................................ Successive approximation

Analog inputs ......................................... 8 single-ended, 4 differential, software selectable

Input resolution
  NI USB-6008 .................................. 12 bits differential, 11 bits single-ended
  NI USB-6009 .................................. 14 bits differential, 13 bits single-ended

Max sampling rate (aggregate)\(^1\)
  NI USB-6008 .................................. 10 kS/s
  NI USB-6009 .................................. 48 kS/s

AI FIFO.................................................. 512 bytes

Timing resolution................................... 41.67 ns (24 MHz timebase)

---

\(^1\) System dependent.
Timing accuracy .....................................100 ppm of actual sample rate

Input range
   Single-ended ....................................±10 V
   Differential .....................................±20 V, ±10 V, ±5 V, ±4 V,
                                              ±2.5 V, ±2 V, ±1.25 V, ±1 V

Working voltage .....................................±10 V

Input impedance .....................................144 kΩ

Overvoltage protection ...........................±35

Trigger source .....................................Software or external digital
                                              trigger

System noise²
   Single-ended
      ±10 V range ...................................5 mVrms
   Differential
      ±20 V range ...................................5 mVrms
      ±1 V range ...................................0.5 mVrms

Absolute accuracy at full scale, single ended

<table>
<thead>
<tr>
<th>Range</th>
<th>Typical at 25 °C (mV)</th>
<th>Maximum over Temperature (mV)</th>
</tr>
</thead>
<tbody>
<tr>
<td>±10</td>
<td>14.7</td>
<td>138</td>
</tr>
</tbody>
</table>

Absolute accuracy at full scale, differential³

<table>
<thead>
<tr>
<th>Range</th>
<th>Typical at 25 °C (mV)</th>
<th>Maximum over Temperature (mV)</th>
</tr>
</thead>
<tbody>
<tr>
<td>±20</td>
<td>14.7</td>
<td>138</td>
</tr>
<tr>
<td>±10</td>
<td>7.73</td>
<td>84.8</td>
</tr>
<tr>
<td>±5</td>
<td>4.28</td>
<td>58.4</td>
</tr>
<tr>
<td>±4</td>
<td>3.59</td>
<td>53.1</td>
</tr>
<tr>
<td>±2.5</td>
<td>2.56</td>
<td>45.1</td>
</tr>
</tbody>
</table>

1  ±20 V means that |AI+ – (AI–)| ≤ 20 V. However, AI+ and AI– must both be within ±10 V of GND. Refer to the Connecting Differential Voltage Signals for more information.

2  System noise measured at maximum sample rate.

3  Input voltages may not exceed the working voltage range.
Analog Output

Analog outputs ....................................... 2
Output resolution.................................... 12 bits
Maximum update rate ............................ 150 Hz, software-timed
Output range........................................... 0 to +5 V
Output impedance .................................. 50 Ω
Output current drive ............................... 5 mA
Power-on state........................................ 0 V
Slew rate................................................. 1 V/μs
Short circuit current ......................... 50 mA
Absolute accuracy (no load) ................. 7 mV typical,
36.4 mV maximum at full scale

<table>
<thead>
<tr>
<th>Range</th>
<th>Typical at 25 °C (mV)</th>
<th>Maximum over Temperature (mV)</th>
</tr>
</thead>
<tbody>
<tr>
<td>±2</td>
<td>2.21</td>
<td>42.5</td>
</tr>
<tr>
<td>±1.25</td>
<td>1.70</td>
<td>38.9</td>
</tr>
<tr>
<td>±1</td>
<td>1.53</td>
<td>37.5</td>
</tr>
</tbody>
</table>

Digital I/O

Digital I/O
P0.<0..7>......................................... 8 lines
P1.<0..3>......................................... 4 lines
Direction control ................................ Each channel individually programmable as input or output
Output driver type
NI USB-6008 ............................. Open collector (open-drain)
NI USB-6009 ............................. Each channel individually programmable as active drive (push-pull) or open collector (open-drain)
Compatibility ......................................TTL, LVTTL, CMOS

Absolute maximum voltage range ..........–0.5 to 5.8 V with respect to GND

Pull-up resistor ....................................4.7 kΩ to 5 V

Power-on state .....................................Input

Digital logic levels

<table>
<thead>
<tr>
<th>Level</th>
<th>Min</th>
<th>Max</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input low voltage</td>
<td>–0.3</td>
<td>0.8</td>
<td>V</td>
</tr>
<tr>
<td>Input high voltage</td>
<td>2.0</td>
<td>5.8</td>
<td>V</td>
</tr>
<tr>
<td>Input leakage current</td>
<td>—</td>
<td>50</td>
<td>μA</td>
</tr>
<tr>
<td>Output low voltage (I = 8.5 mA)</td>
<td>—</td>
<td>0.8</td>
<td>V</td>
</tr>
<tr>
<td>Output high voltage</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Active drive (push-pull), I = –8.5 mA</td>
<td>2.0</td>
<td>3.5</td>
<td>V</td>
</tr>
<tr>
<td>Open collector (open-drain), I = –0.6 mA, nominal</td>
<td>2.0</td>
<td>5.0</td>
<td>V</td>
</tr>
<tr>
<td>Open collector (open-drain), I = –8.5 mA, with external pull-up resistor</td>
<td>2.0</td>
<td>—</td>
<td>V</td>
</tr>
</tbody>
</table>

External Voltage

+5 V output (200 mA maximum) ............+5 V typical, +4.85 V minimum

+2.5 V output (1 mA maximum) ............+2.5 V typical

+2.5 V accuracy ................................0.25% max

Reference temperature drift ..............50 ppm/°C max

Counter

Number of counters ..........................1

Resolution ....................................32 bits

Counter measurements .....................Edge counting (falling-edge)

Counter direction ............................Count up

Pull-up resistor ..............................4.7 kΩ to 5 V

Maximum input frequency .................5 MHz

Minimum high pulse width .................100 ns
Minimum low pulse width................. 100 ns
Input high voltage ......................... 2.0 V
Input low voltage ......................... 0.8 V

**Bus Interface**

USB specification ......................... USB 2.0 Full-Speed
USB bus speed ......................... 12 Mb/s

**Power Requirements**

USB
4.10 to 5.25 VDC......................... 80 mA typical, 500 mA max
USB suspend......................... 300 μA typical, 500 μA max

**Physical Characteristics**

**Dimensions**
Without connectors......................... 6.35 cm × 8.51 cm × 2.31 cm
(2.50 in. × 3.35 in. × 0.91 in.)
With connectors......................... 8.18 cm × 8.51 cm × 2.31 cm
(3.22 in. × 3.35 in. × 0.91 in.)

I/O connectors............................... USB series B receptacle,
(2) 16 position terminal block
plug headers

**Weight**
With connectors......................... 84 g (3 oz)
Without connectors......................... 54 g (1.9 oz)

**Screw-terminal wiring**................. 16 to 28 AWG

**Torque for screw terminals**........... 0.22–0.25 N · m
(2.0–2.2 lb · in.)
Safety

If you need to clean the module, wipe it with a dry towel.

Safety Voltages
Connect only voltages that are within these limits.

Channel-to-GND ....................................±30 V max, 
Measurement Category I

Measurement Category I is for measurements performed on circuits not directly connected to the electrical distribution system referred to as MAINS voltage. MAINS is a hazardous live electrical supply system that powers equipment. This category is for measurements of voltages from specially protected secondary circuits. Such voltage measurements include signal levels, special equipment, limited-energy parts of equipment, circuits powered by regulated low-voltage sources, and electronics.

Caution Do not use this module for connection to signals or for measurements within Measurement Categories II, III, or IV.

Safety Standards
This product is designed to meet the requirements of the following standards of safety for electrical equipment for measurement, control, and laboratory use:
• IEC 61010-1, EN 61010-1
• UL 61010-1, CSA 61010-1

Note For UL and other safety certifications, refer to the product label or visit ni.com/certification, search by model number or product line, and click the appropriate link in the Certification column.

Hazardous Locations
The NI USB-6008/6009 are not certified for use in hazardous locations.

Environmental
The NI USB-6008/6009 device is intended for indoor use only.

Operating temperature
(IEC 60068-2-1 and IEC 60068-2-2)......0 to 55 °C

Operating humidity
(IEC 60068-2-56) .................................5 to 95% RH, noncondensing
Maximum altitude .......................... 2,000 m (at 25 °C ambient temperature)

Storage temperature
(IEC 60068-2-1 and IEC 60068-2-2) .......... –40 to 85 °C

Storage humidity
(IEC 60068-2-56) .......................... 5 to 90% RH, noncondensing

Pollution Degree (IEC 60664) .............. 2

### Electromagnetic Compatibility

This product is designed to meet the requirements of the following standards of EMC for electrical equipment for measurement, control, and laboratory use:
- EN 61326 EMC requirements; Minimum Immunity
- EN 55011 Emissions; Group 1, Class A
- CE, C-Tick, ICES, and FCC Part 15 Emissions; Class A

**Note**  For EMC compliance, operate this device with double-shielded cables.

### CE Compliance

This product meets the essential requirements of applicable European Directives, as amended for CE marking, as follows:
- 2006/95/EC; Low-Voltage Directive (safety)
- 2004/108/EC; Electromagnetic Compatibility Directive (EMC)

**Note**  Refer to the Declaration of Conformity (DoC) for this product for any additional regulatory compliance information. To obtain the DoC for this product, visit [ni.com/certification](http://ni.com/certification), search by module number or product line, and click the appropriate link in the Certification column.

### Environmental Management

National Instruments is committed to designing and manufacturing products in an environmentally responsible manner. NI recognizes that eliminating certain hazardous substances from our products is beneficial not only to the environment but also to NI customers.

For additional environmental information, refer to the *NI and the Environment* Web page at [ni.com/environment](http://ni.com/environment). This page contains the environmental regulations and directives with which NI complies, as well as other environmental information not included in this document.
Waste Electrical and Electronic Equipment (WEEE)

EU Customers  At the end of their life cycle, all products must be sent to a WEEE recycling center. For more information about WEEE recycling centers and National Instruments WEEE initiatives, visit ni.com/environment/weee.htm.

电子信息产品污染控制管理办法（中国 RoHS）

中国客户  National Instruments 符合中国电子信息产品中限制使用某些有害物质指令 (RoHS)。关于 National Instruments 中国 RoHS 合规性信息，请登录 ni.com/environment/rohs_china。（For information about China RoHS compliance, go to ni.com/environment/rohs_china.）

Where to Go for Support

The National Instruments Web site is your complete resource for technical support. At ni.com/support you have access to everything from troubleshooting and application development self-help resources to email and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also has offices located around the world to help address your support needs. For telephone support in the United States, create your service request at ni.com/support and follow the calling instructions or dial 512 795 8248. For telephone support outside the United States, contact your local branch office:

Australia 1800 300 800, Austria 43 662 457990-0, Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, Canada 800 433 3488, China 86 21 5050 9800, Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, Finland 358 (0) 9 725 72511, France 01 57 66 24 24, Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400, Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, Singapore 1800 226 5886, Slovenia 386 3 425 42 00, South Africa 27 0 11 805 8197, Spain 34 91 640 0085, Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, Taiwan 886 02 2377 2222, Thailand 662 278 6777, Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 52354